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9/21/2016

Agenda

# TransCAD Overview and Navigation

# Formatting and Viewing Data

# Data Tables and Joining Data

# Printing Maps using Layouts

# Looking at SCAG Highway Assignment
# Roadway Network Editing

# Running the SCAG Model

# Advanced Topics?

TransCAD Software Overview

Transportation data management and analysis

GIS based transportation planning analysis

TransCAD:

» Let’s you store, retrieve, analyze, and visualize geographic
data in new and useful ways

» Has tools to apply sophisticated transportation, operations
research, and statistical models.

» GISDK (development computer programming language)

# Version & build

» Version | have open: Version 6.0 r2 Build 9080 32-bit

» 64-bit vs. 32-bit

Vv

TransCAD User Interface
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* For objects on the map — not for

GISDK toolbox geographic editing
— Usually docked at the
e Rl ] | bottom of the window

» Model Calibration/Estimation Utilities
» GIS-Based Roadway and Transit Data
» Intermediate Results Analysis
» Matrix Editor

» Spatial Analysis Tools
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Caltrans District 8 TransCAD and SCAG Model Training 9/21/2016

Built In Interface Batch Mode Customized Interfaces
# Created with the GISDK scripting language

# Provides an interactive method of running a # Settings from the interface can be saved
Travel Model

i . . # Utilize Batch Mode to automate tasks "

# With looping, repetitive tasks can be
automated (e.g., run assignment 5 times with
different input data but mostly similar settings)

& Utilize customized code to streamline

# Very flexible, but can and customize model processes

be a bit tedious to use

% Makes running and analyzing
# Is enhanced through scenarios easy and efficient
use of customized
“Add-Ins”
e et | b B
Open Architecture Compatible File Formats GIS Applications
# Allows for inclusion of any amount or type of data & TransCAD can read and write data to/from # Use TransCAD model results in ArcGIS to create high
i 1 li b
# Requires deliberate and careful definition of input many universally accepted file formats. quality maps
data requirements » GIS (Shapefile, Geodatabase) # Link TransCAD networks to GIS-based analzsis tools.
# Almost any aggregate travel model algorithm that can » Spreadsheet i
be thought up can be implemented in TransCAD » Database
= oo » Text

» HTML (with add-in)
» Traffic Software (with add-in)
» Others
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File and Data Types

# Data Files actually contain information:

» Tables (.bin, .DBF)

» Geographic Files or Layers (.dbd, .shp)

» Matrices (.mtx)
-~
R

< =

&
< <
< P -

File and Data Types

# Some files do not contain information:
» Dataviews (.dvw)
» Maps (.map) and workspaces (.wrk)
» Matrix Views (.mvw)

# These files refer to other file types that contain data
» Same concept as a project file (.mxd) in ArcMAP

Never use File > Save As 2>
“Dataview (.dvw)” or “Map (.map)”
to save a copy for modification!

File and Data Types

# Geographic Files (.dbd) are GIS layers and can be
edited and viewed.
» We use line layers as “roadway networks”

# Route Systems (.rts) contain transit information
» Route systems are linked to line layers

# Routable Network Files (.net, .tnw) are routable
networks used internally by TransCAD.

» Routable network files must be created before running certain
tasks.

» Separate networks for roadway and transit

Useful Features

% Saved Workspaces -
Undo and Redo

v

# Copy and Paste directly
between TransCAD and other =
programs (e.g., Excel)

# The Display Manager [ B ==
» Show it from
Map > Display Manager

% Multiple selection sets ‘%
% Many more... =

New in TransCAD 6.0, 7.0

# Read and write directly to ESRI Geodatabases
# Improved Mapping Features

» Label customization
» Transparency # TransCAD 7
» Even More

# Under the Hood multithreading
» 64-bit architecture » Improved transit
» More multithreading management
» New procedures » Improved elevation
(e.g., drive egress to data
transit) » Pivot tables and
charts
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Map Basics: Visualizing

CAMBRIDGE SYSTEMATICE ,

9/21/2016

Working with Layers

& Start by opening a map or a geographic (dbd) layer
file

» Opening a layer will create a new map and add the layer
» Opening a map will load all saved layers, settings, etc.

# Access layers with the layers dialog box (£ )
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Working with Layers

= The Layers Dialog (& )
Layers. - 5 3
Layersin Order ofDisploy_Sormple_Seats Hide/show a
= = layer
! Add/Drop
| layers
[ e | [ | [noncren] —y......&r ‘;...:.. Re-order
e e aiinress layers

Add/edit labels
layer style E
5] =

Automatically
show/hide layers
as certain scales

CAMBRIDGE SYSTEMATICE ,

Working with Layers

= Layers are drawn from TOP to BOTTOM

Top layer
(drawn first) L -5

|

Uayersin Ordes of Disley_ Sompée_ Seatus
Node o b

i

e
Add Layer
[owaine |

e el —

Gacgraghic File | C4_5RIESS, el suting\ metweskspt 16615 p finks DB

Bottom layer
(drawn last)
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Display Manager

% Activate from Map - Display Manager

% Quick access to layers, settings, etc.

» Right-click for more settings, including make
working layer

Hide/show a
layer
Add/edit labels
Change a
layer style

Node layer is
active

Bold text: links
layer is active

{

CAMBRIDGE SYSTEMATICE

Color Theme
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Creating Maps

» Create a new map by opening a Geographic File (*.dbd)
# Add more layers if desired

» £ then Add Layer

# Choose the active layer 7 & i osier oown T fasaie
SRS~ N o] 1

» Use the dropdown selector % % % %% E}‘ﬁ_g#
(s

» Or use the display manager

# Change the “default” styles for the layers
» £ then _ Sue. , or @ , or use the display manager

# Hide or show layers
» g% or the display manager

. e ar )

9/21/2016

Color and Pattern Themes

# Set feature colors and styles based on
attributes
» Color Themes (| ) are often used to display
facility type on a roadway network
» Pattern Themes (Map > Pattern Theme...) is
sometimes used to display number of lanes on a
roadway network

Color and Pattern Themes

The Settings Tab 1. Choose a field to
[ o st s T represent
S [
. 2. Choose a method to
P - create categories and
et @ e number of classes
* Use the Load and Save
buttons to store and recall
settings
B »  This is a huge time-saver!
i
o] (e ) dow ] (o) i

Color and Pattern Themes
The Styles Tab |

Choose a style for

e e each class
— @ 2. Select a legend text
— for each class

3. Choose from pre-
defined color settings
if desired

Functional Class

Primary Facilty Type Secondary Facilty Type Primary Faclty Type Secondary Feciity Type
1 Freoways 10 Freeway i 70 Undiided
=y 20 Hov2 71 Divided
21 Hov 3+ 72 Continuous Left Tum
22 HOV - HOV Comector 73 Posted Speed 25
3 Expressiy [PaRRY 35 Unguided 74 Posted Speed 15
31 Dwvided, Inemupted 8 Ramps 80 Freeway 1o Freeway Comector
32 Divided, Unintemupted 81 Freeway to anerial
& o= 20 Undivided 82 Arteral 1o freeway
a1 Dwvided 3 Ramp Distrbuor
42 Continious Left Tum 84 Ramp from Arerial 10 HOV.
& Pl 50 Undivided 85 Ramp from HOV to Arterial
51 Divided 86 Collector distrbutor
52 Continious Left Tum 87 Shared HOV Ramps (o MF
O [EEeEl=E 60 Undivided 88 Truck orly
61 Divided 9 Trcks % Trck orly
62 Continious Left Tum 100 100 Certroid Comector - Tier 1

200 Centrold Connector - Tier 2.

Source: SCAG Model =
Documentation, Appendix A

30 CAMERIDGE SYSTEMATICE "

Functional Class

< Two Digit FT Codes
» Contained in AB_Facility_Type and BA_Facility_Type
» Difficult to use for map editing setup (too many details)

< One Digit FT Codes
TransCAD
Formulas.txt

» Not stored on the network
» Can be computed /

i fzmme s s T g e
i SR IS o B - 6 i 0 it
B 5

ot 1:1

.
< 4 then s CTeft (s
). 1

Pacan_rac 11 {ey_typed, 1)
CEaFac Tty_Tyen

1 Ganract ey rype = 100 or Basact ey Type - Jom then 100 slsa
)

Note: We will discuss formulas
in more detail in a later section




Practice 1: Create a color theme for line layer using IFC field

1. Open the SCAG Network File (16R16pl_links.dbd)

v File>Open, then in the file type dropdown next to ‘File name:” select Geographic File(*.cdf,.*dbd) option
v" Browse to the location/folder where the geographic file is located and select the ‘abmload.dbd’ and click ‘Open’

button

2. Add the MAP_FT Formula Field
v' Dataview—>Formula Fields
v" Open TransCAD Formuals.txt in notepad, then copy the MAP_FT formula
v" Paste the formula and name the formula MAP_FT
v Click OK

On the top ribbon, click . it is called ‘color theme map wizard’

It opens up a dialog box with two tabs. In the first tab ‘Settings’ tab:
v Select the MAP_FT from the ‘Field’ drop down options

v" Select the ‘List of Values’ from the ‘Method’ drop down options

v" Max. Classes: Use the default value (512)

5. Go to the ‘Styles’ tab
v Observe the default styles
v Optional: Set a preferred style for each facility type (we will use a shortcut)

6. Go back to the Settings tab, click the Load button.
v" Choose From Settings File
v/ Browse to and select SCAG Training\Settings.stg
v" Choose MAP_FT and click OK
v Click OK again to complete the color theme dialog box
7. Save the settings (optional, method 1) Skip this step in training.
v" Tools = Geographic Utilties = Geographic file
v" Click Save Settings
1. Save the settings (optional, method 2) Use this method in training.
v File —=Save As
gz Save a Map file that you can open later with the settings applied

g

Formula (Dataview: 16rl6p_links) | 2 |
if (AB_Facility_Type = 100 or BA_Facility_Type = 100) then 100 | QK I
else
if (AB_Facility_Type = 200 or BA_Facility_Type = 200) then 200
glse N . Delete
if (AB_Facility_Type = 999 or BA_Facility_Type = 999) then 999
if (AB_Facility_Type > 0) then s2i{left(string(AB_Facility_Type), -
;|
else s2i(left(string(BA_Facility_Type), 1)) Mode Fields...
Formula Builder Formula Fields Sum Fields...
Field List... - paap_FT - Save...
- Load...
Operator List.., - Previous Formulas o2
Functicn List... - -
Values... -
[ Golor Theme (Layer: 16:16p links) / s | — )
Settings Styles
General
Field MAP_FT - Save..
Method  List of Values - Load... "
Max Classes -
Options
Ignore values below “ | or abowve “ |
Stl, Dew, per class
Break at
Treat zeros as missing values
Round off the values in each class
i [[lInclude counts in legend
U
I ﬁ
[0k [Cancel ] [_Apply | [ Remove ] [Costomizel || CAMBRIDGE SYSTEMATICS
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Automatic Labels

# Labels () can be used to show things
including:
» Traffic Volumes
» Number of Lanes
» Centroid Numbers

» SED/Land Use Data

# Labels can be set differently for different
selection sets

CAMERIDGE EYSTEMATICE i

Automatic Labels

The Labels Tab
“;%“;’:L".L =
' &

1. Select the field to use
for labels
2. Set label placement
options
» Note the “Allow
Duplicates” checkbox

3. Set the label style
options

CAMBRIDGE SYETEMATICE ,

Automatic Labels

The Overlaps Tab

Cl

[Fer—y)

| Orote | Backgonrd | oot |
s
PN
o erm
Lo oy 7w
e e e e cn Hghr
ke Lo

et S [T (=]

# Overlapping labels can
be allowed if desired

~ Different layers can
have different priorities

& Autoscale can turn
labels on and off
automatically

CAMBRIDGE SYETEMATICE ,

Automatic Labels

The Background Tab

Labets (e, smioad_byrh B ]

Tiom

e

[ Lab | vndag | B [Coloas

®—
=
90—
Q) e

=
9

& Shadows, halos, frames,
or shields can be added
to labels to create better
looking and more
informative maps

CAMERIDGE SYSTEMATICE ,

Automatic Labels

The Callouts Tab

Labets (Luper: sbmicad bye] I
Lo | vt | kg | S |
h
1| v o
o
Tk (Cred | [y Femom |

# Set the default callout
style to use when labels
are manually re-
positioned

CAMBRIDGE SYETEMATICE ,
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Practice 2: Add number of lanes labels

TIP

1. Start with the results from Practice 1
v" Open the saved map if needed

Use the and zoom-in tool ( @&, ) to zoom in to the area of interest

On the top ribbon, click the labels icon ( #_])

v Select the [AB_AMLANES/BA_AMLANES] field

v~ Change the size and color to match your preference

v" Change the format to have numbers by comma separated
v Click ‘OK’ button

In training, save the map for future use

39

rs e
Labels (Layer 16r16p._links) /

|
(|
Do net display on the map
N‘
12 B

Labels | Overlaps | Background | Caiioms|

General

| ypFicld [AB_AMLANES /BAAMLANES] ~ | save.. |

Position Centered above - Load...

Rotation Along line features =
Smart Alignment [ Stretch Skip Partial Labels
[¥] Allow Duplicates Spacing ’0— Inches il
Limit Lines o Characters

@SimSun-ExtB o Size
~~phgency FB
Aharoni [ Color NN ~
Algerian
Andalus ormat 12,345 -
Angsana Mew \q
AngsanalPC Line Height | 100 %
Aparajita )
Arabic Transparent Bold [ | ltalic
Arabic Typesetting
le Shows what Label Text will
l oK I [ Cancel ] [ Apply ] Remove
= — 2

CAMBRIDGE SYSTEMATICS i
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Create Scaled Symbol Theme

(also known as bandwidth map)

CAMBRIDGE SYSTEMATICE ,

Create Selection Sets

9/21/2016

Scaled Symbol Themes

% Scaled Symbol Themes (%% ) are often used
to:

» Display traffic volumes

a1

Scaled Symbol Themes

The Settings Tab # Show directional fields
only, or all fields

Sty e Ly miond byl

# Select a field to use

# Specify a scale, or let
TransCAD specify one
automatically

[P

Coced | [_soohy | | Peraee |

CAMBRIDGE SYSTEMATICE ,

Selection Sets

» Add additional formatting capability
» Useful for analysis and data processing

# Use the Selection Set Toolbox
» Select items with a query

. - abmioad_byr Selection (@]
» Select items by pointing DENCE NN Ty Y
» View the Selection Settings ||siswn [

# One map can contain many selection sets
» Show or hide selected items

» Format selected items with different colors, styles,
and labels

CAMBRIDGE SYSTEMATICE ,




Practice 3: Create selection sets and color and label them

»  Start with the results from Practice 2
v" Open the saved map if needed

1. Goto Tools and select ‘Selection’ or hit F9

Selection ()

v" This will show the selection toolbox shown to the right
v" Click select by condition ( |‘€‘£} ) to open the query builder
v" Type in condition: MAP_FT >= 100

V" Type the Set Name (Connectors) [ select by Condition (Dataview: lﬁrlﬁpjli;iks) |.i.|ﬁ
- - r
2. Change the centroid connector lane labels e
. . _ _ MAP_FT >= 100
v/ Open selection settings (Selection > Settings or &u )
v" Choose Connectors, then click Style
v Set the color to “default gray) — this allows the color theme to | Condition Builder Set Name
. Cl
override | Field List... - Connectors -
v Click Labels Operator List . Selection Method
. . - Load...
v Set the label to a smaller font size and different color — Create Set =
Function List... -
v Close the selection settings et
Values... - v|
! Previous Conditions
) . Select from visible features only pap FT = 0 -
v TIP: You can make other changes to multiple different

ke = — e— e ’,

selection sets, or can hide some features altogether!

In training, save the map for future use

45 CAMBRIDGE SYSTEMATICS i
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Data Tables (“Dataviews”)

CAMBRIDGE SYETEMATICE ,
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Working with dataviews

# Open a dataview for any existing layer (E)
# Open a standalone table with File - Open

# Add/Remove fields with Dataview > Modify Table
» (or g&')

» Be careful: Changes are permanent once you click “OK”

# Data can be edited directly in the dataview
» Be careful: Changes are saved as you go

# Create formula fields with %2

# Right-Click on a column header for more options
» Including a formula Fill

47 CAMBRIDGE SYSTEMATICE i

Working with Dataviews

% Formula Field vs. Add Field & Formula Fill
» Formula Fill adds new data and saves values in the table

» Formula Fields are updated when other values change, but are not
stored in the data table
= Formula fields are stored in a map, dataview (*.dvw), or workspace (*wrk)

1. Enter aformula

2. Use the Field List to find
field names

3. Name the formula field

Tip: nz([Field]) converts null
values to zero values

48 CAMBRIDGE SYSTEMATICE ,




Practice 4: Add total number of lanes in a NEW FIELD

("Modity Table - ==
Table Specifications :§
N Field Name | Type Widt | Dec | Index | Default| Format Display Name - oK
AB,EVE,FX,TOL‘R::(sme;] ‘m |3 ‘D | ‘ one ‘ = ‘ Cancel
»  Start with the results from Practice 3 o e 5T T
‘/ Open the saved map |f needed BATOLLVEVET Real (8 bytes) 10 3 O None
ABNT_PM_TOI Real @bytes) 10 |3 | [ None
BA_NT_PM_TOI Real (8 bytes) 10 3 O Nene m
1. On the top ribbon, click it will open the links layer e e
daataVieW table ABTOLLVNTT Real @Bbytes) 10 |3 | [ None Drop Codes
BATOLLVNTT Real (8 bytes) 10 3 O Nene __ | |Export Codes
] ) ] O Fel Ebte) 10 3 [ None 4
2. Use Dataview - Modify Table or click CS =T | || Feldpescripion
v Click ‘Add Field’ Sl
. Record Information
v" Name the field “TOT_LANES” Add Records Settingn
v" You can move the field position using Move Up and Move
Down buttons to the right
. Fill = ]
v Click ‘OK’
Fill Method
3. Go to ‘Dataview’ window B sasie il
) 3 i () Sequence Start |1 Step |l
v" Right click the top part of the ‘TOT_LANES’ field © Fommui|
v Select ‘Flll’ .:::.T'Furmula [Dataview: 16r16p_links)
el | | nz(AB_AMLANES) + nz(BA_AMLANES) 0K
v . . ) .
Select the ‘Formula’ in the fill method options .
. Delete
v' Type: nz(AB_AMLANES) + nz(BA_BALANES)
v' Alternatively you can use the formula builder '
B
v CI'Ck ‘OK, button Formula Builder Forrmulz Fields
, his fills i b l & )| Field List... - |
This fills in two-way number of lanes | o d| opssortie. 21| previoss rormiie
Function List... - if (AB_Facility_Type = 100 or BA_Facility_Typ +
—1| Values of BA_AMLANES...

CAMBRIDGE SYSTEMATICS i
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Joining Data

CAMBRIDGE SYETEMATICE ,
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Joining Data

# Layers have an associated data table (E)

# Data can be joined (3€ ) to other tables
» Roadway Network + Traffic Assignment results
» TAZ layer + Land Use Data
» Roadway Network + Lookup Table
» More...

# This is how traffic assignment results are
viewed in TransCAD

51 CAMBRIDGE SYSTEMATICE i

Joining Data

1. Select the Primary join table
»  Be careful: Check the Field

et | s

st
e lﬁ VAL Ll
) S
o [ICT

2. Select the secondary join
table

»  Be careful: Check the Field

raf
ek 224552880
T
(o 3. Create a name for the view,
or use the default (do this

last)

ke
Somhe: 1,24 RE7AS 10

Lamos

Tip: You can open a file from the join dialog box

T

'niﬁ]fhﬂ =
S ﬁ
52 CAMERIDGE SYSTEMATICE




Practice 5: Join the TAZ data to the TAZ layer (Tier 1)

1. Start with the results from Practice 4
v" Open the saved map if needed

2. Add the TAZ layer to the map
v Open the Layers dialog ( &% )
v" Click Add Layer

v/ Browse to:
16R16s3_set7_setting\Geography\TAZ_t1.dbd

v" Move the TAZs to be drawn first (top of the list)
v~ Click ‘Close’

3. Open the TAZ Data Table
v" File > Open

v" File Type Comma- or Tab-delimited Text
V" Browse to

\16R16s3_set7_setting\SED\Inputs\TAZ_t1.dbd\

T1 2016 Control_PolicyA_vi63_013116.csv

v/ Note that this is opened as read-only (all cells are green)

4, Create a join from Dataview - join or 3
v' Set the left side of the join to TAZ_t1, field ‘ID’

v
v
v" Click ‘OK’, then use “info” to review the data
v

Warning: Do NOT close the joined view!

53

Layers = ]
Layers in Order of Display ~ Sample Status

T T
Node . Hidden

16116p_links —

Add Layer

‘ Move Up |

]

Style... ” Labels... HAutoscaIe...” Rename... ] [ Metadata ]

Geographic File | Ci\... Training\16R1653_set7_setting\Geography\TAZ_t1.DBD

Set the right side of the join to T1_2016_Control_PolicyA vi63_01
Set the right side join field to TAZ *NOT TAZPREV

-
Join

Settings Options

Create Joined View

Joining from (left side of join)

Mame | TAZ t1+T1_2016_Control_PolicyA_vi63_01

Table TAZ t1

-

Field 1D

-

i Examples | 43594000, 43588000, 53995000, 43595000, 5388501

To (right side of join)
Table T1_2016_Control_PolicyA_vi63_01 -
Fed -

Examples |14UUUUUU, 14001000, 14002000, 14003000, 140040(

[ ok || canca |

N —— ——

—_—

CAMBRIDGE SYSTEMATICS i



Caltrans District 8 TransCAD and SCAG Model Training

Printing Maps (Layouts)

Layouts

# Allow users to create a page to be printed
» Set paper size
» Set a specific printer PDF writers work best!

# Created from File > New
& Print maps, drawing items, tables, and insets
# Add titles, legends, etc.

CAMBRIDGE SYSTEMATICE i
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Practice 6: Create a Layout with your map

1. Start with the results from Practice 5
v" Open the saved map if needed

2. Create a new layout using File = New or [
v

v
v
v

3. Add your map to the layout using ]

v" Draw a box to place the map
Select Map, check ‘Use actual point sizes’
v" Optionally un-check ‘Keep map’s aspect ratio’
v" Click ‘OK’
4, Position and edit the legend
v' Use the pointer tool ( [; )
v Drag the legend to a good location
v

Check the page settings with File = Properties or %
Select a printer and page size

Set to landsape

Important: Un-check Change size of items when page size changes

Double-click to edit legend text and contents

5. Add a legend title

v

v
v

56

Use the ‘Freehand Text tool ( A ), usually at the bottom of the
window

Drag a box, then type a title

Use the pointer to reposition, double-clicking to edit

p
Layout Properties

General

Tile Untitled

Stored in:  None

Prirter

Name: [ adobe PDF - [ Properties
Status:  Ready
Type: Adobe PDF Converter
Where:  Documents\” pdf
Comment:
Page Criertation
Size: [Leﬂer v] =

() Portrait

Dimensions:

1 [+ Pages Across 1 1+ Pages Down @ Landscape

Change size of tems when page size changes

Margins {in inches)

Top 0.250 ﬂ Bottom 0.250 ﬂ Left 0.250 ﬂ

Right 0.250 ﬂ

Example Layout

CAMBRIDGE SYSTEMATICS i



Caltrans District 8 TransCAD and SCAG Model Training

More on Networks and Zones

CAMBRIDGE SYETEMATICE ,

User Variables

# Creating your own variables
» Additional fields can be added to links & nodes
layers

» Field names can contain spaces and numbers, and
do not have a practical limit to the number of

User Variables

# Creating your own variables

» Itis preferable to:
= Limit field names to 10 characters
= Avoid using spaces
= Avoid starting a field name with a number

Centroids

# Centroids are special nodes that are linked to
socioeconomic data
» SCAG’s Model has three tiers of TAZs
= Tier 1: Least amount of detail
= Tier 2: More detail
= Tier 3: Used for subarea models.
» TAZ numbers match the TAZ
layer, data tables, and matrices

= Sometimes, files use sequential
TAZ numbers instead!

CAMBRIDGE SYETEMATICE ,

characters » If these guidelines are followed, compatibility with
other GIS programs will be improved
= Field names that do not follow these guidelines will have
» HOWEVER... truncated or confusing names when exported to a
shapefile
55 CAMERIDGE SYETEMATICE - s9 CAMBRIDGE SYETEMATICE E
Centroids Tiered TAZ Structure

# Nodes are identified as centroids using the
following rules:

Field Name

TierlTAZ User friendly nested TAZ ID numbers
Tier2TAZ (sequenced by county, type, etc)
ZoneType_Tierl Internal, External, Airport, or Seaport

ZoneType_Tier2
Internal_sequence_id_T1 TAZ numbers used internally by

B TransCAD — but important to model
Internal_sequence_id_T2 =S

CAMERIDGE SYSTEMATICE ,

# Tier 1 Zones # Tier 2 Zones

4,192 11,350

» Used in traffic » Used in trip
assignment generation,

» Results in 17.5 distribution, and
million cells per mode choice
matrix » Results in 128.9

; million cells per
Fun with Math: matrix

Why these models take so long

62 CAMBRIDGE SYSTEMATICE ,
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Highway Assignment

9/21/2016

Learned by Example

# Creating maps

# Adding layers

& Setting layer styles, labels, and themes
# Working with data tables

# Joining Views

# Creating layouts for printing

Insight into the SCAG model

# Saw the SCAG network
» Facility Type
» Lanes
# Saw the SCAG TAZ layer and data table
» Various input SED values
» Saw how to join to TAZs
» Note: TAZ vs. SEQ (sequential TAZs)
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Assignment Results

# Basic Volumes
» Located on the Loaded Network
» Assign\Output\scag_network_loaded.dbd

# Volume and Travel Time for:

» Each Period
(AM, MD, PM, NT, EVE)
» Total daily

Assignment Results

# Detailed Results in a separate table
» Join to the network using ID & ID1 =
» By time period or daily
» In the assign\Outputs folder

# Processed version in ‘emission’
» Adjusted as part of SCAG'’s air quality
modeling process

» Can be used if desired, but be
consistent within a project!
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Assignment Results

# Detailed Results include:

» Basics:
= Total Flow
= Flow by class (e.g., drive alone, shared ride, truck)
= Travel time and speed (congested time by period)
» Extras / Statistics:
= VMT (called V_Dist_T)
= VHT
= Volume to Capacity Ratio (“VOC”)
= PCE Values
» Select Link / Zone Results

= Only present if mode was run with
assign\Inputs\SelectLink.qry




Practice 7. Review Assignment Results

1. Open the output roadway network
v" Use File > Open
v' Browse to Assign\Outputs\scag_network_loaded.bin
v" Review the build-in assignment results

2. Open the detailed assignment results
v" Use File > Open
v" Browse to Assign\Outputs\day_flow.bin

3 Create the join from Dataview - Join or
v Left side: link layer and ‘ID’
v" Right side: day_flow and ‘ID1’
v" Click ‘OK’
v" Remember: Do not close the joined view.

4, Use the info tool to review the results

Challenge: Apply what you've learned

5. Label the links with the % share of vehicles that are “Drive Alone”
(Hint: create a formula field)

6. Try creating a bandwidth (scaled symbol) theme showing directional volume
(hint: Use #% )
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Roadway Network Editing

Network Editing

# Warning: Make a backup copy first!
» There is an “Undo” function in TransCAD

» Edits are made directly
to the network file: You
can't close without saving

to discard changes
» Network files sometimes become corrupt

Network Editing

& Backing up the Roadway Network

# Method 1 (recommended): e,
» Open the network in TransCAD L
» Use Tools > Geographic Utilities 2> | wa

G b by

Geographic File I oo e Loms
» Click Archive to save in a zip file A
% Method 2 (advanced): o

» Close all files in TransCAD

» Create a zip file with the line layer
and route system files

» Make sure to get all related files

Network Editing

# Once you have made a backup, you can:
» Edit attributes of existing links
» Change data for a specific year or for multiple
years and alternatives
» Add new links, delete existing links, or realign
existing links
» Add data for a year not yet included in the network

Network Editing

- Edit attributes of existing links

» Display settings can assist with editing
# Additional labels and/or

themes can be useful

» Label # of lanes or other
values

» Show Topology ( % )
to see AB vs. BA

Network Topology

# Show topology to identify AB and BA
directions

. ol _-—o

AB East to West
BA West to East

AB West to East
BA East to West

# To identify one-way roads, use the DIR field:
» 0: Two-way travel
» 1: A > B travel
» -1: B > Atravel
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Network Editing

- Edit attributes of existing links — Method 1
» To make most edits, use the information tool ( @ )
and edit text in the form that appears
» Changes can be undone o
= Each edit action creates an undo point
» You can select and fill multiple
links with the information tool

= Multiple values can be filled by
right-clicking on row names

-—Lii-iiii‘—iii ii 1 i i‘Ji|~

Network Editing
Alternate Method

& Edit attributes of existing links BECID “n‘l_.,-\
Alternate Method G
» Use the map editing toolbox ( 4 )

» Use the Edit Line Attributes () button
. g)peration of this tool is similar to using the information
utton

» Edits are saved when the green light ( ¥)) is
clicked
» Use the red ( /) light to cancel all unsaved edits

» The Undo function will undo all edits that are saved
at once with the green light

Network Editing

# What Fields do | Edit???
» Facility Type
= Facility type identifier
» Lanes
= Directional number of lanes, by time period
= Aux. lanes (freeway links only)
» Direction
» Area Type
= Use nearby links as a guide
» MODE
= 2 for most links (other values are for transit)
» Other fields as necessary

Network Editing

# What Fields do | Edit ??? (cont'd)

» Toll coding guidelines
= Use TOLL, Toll_flag
= See assign\inputs\toll_hot_penalty for toll and express
lane coding details
# See the SCAG Model User’s Guide for more
guidance

Practice: Network Editing

# Open the input network file

# Make a backup copy of this network in a
folder called “Backup”

» Use Tools - Geographic Utilities - Geographic
File and archive the network

» Add the date to the backup filename
» Edit the original network file

# Try using the different editing approaches to:
» Change the facility type
» Widen a Road

Practice: Network Editing

# Show Topology on the network

# Change a roadway to represent a different
number of lanes in each direction

# Change a different roadway to a one-way
road

» 0 =Two-Way [
ala-_—. o Ble—e

»1=AtoB

AB = West fo East AB = East fo West
»-1=1t0A BA = East fo West BA = West to East
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Network Editing

# Adding new links

» Use the map editing toolbox (&)

» Add links using Add Line (/%))
= To work properly, links must be connected at nodes
= Existing links may need to be split
= Avoid splitting links if possible

» Make sure that links are connected by:
= Saving edits
= Moving a node around — do all of the attached links move

with it?

= Canceling the edit

Network Editing

% Adding New Links
» New links need new data!

» Copy data from an existing link with similar
characteristics —
Use the Edit Link Attributes (/] ) button
Click/shift-click on the new link(s)
Shift-click on the similar old link
Right-click on the data for the “old” link and choose “Copy
Values”
_ﬁ » Splitting/Joining Links
= Check the split/join settings
= Use the split/join tools ([e«[+»]) |
= New/moved links may be connected at new nodes \
= Check data on split/joined links Jan/5p farbun Setings L .
oo g

o
5|
%%

Network Editing

# Keeping Transit up to date

» Always add the route system to the network before
making edits (link additions, splits, or joins)

» Add the route system from networks\Inputs
Note: Make sure to choose the Route System file type

» Make the route system active after every few edits

» TransCAD will prompt and update the transit network
based on your changes

== =
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Network Editing

Practice: Network Editing

# Continue editing the input network

# Add, delete, and realign some links
» Show topology: Note that the way a new
link is created defines its AB direction

# Copy link values from an old road to newly
created links

& Split and join links
» look at the data that appears on each half
» Look at the network editor settings ( &)

Network Editing

# Things to keep in mind:
» When splitting links, make sure the data on both
pieces still makes sense
» When adding new roadways, adjust centroid
connectors if necessary

» Adding detail or making corrections?
= You may need to make edits to base and forecast
networks

9/21/2016
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Running the SCAG Model

CAMBRIDGE SYETEMATICE ,

Preparing a Computer

# TransCAD 6.0,
» build 9215 or later
» 64-bit verison required
» TransCAD 7 not supported (yet)

# Minimum System Requirements
» 24GB RAM
» 12 CPU cores
» 500 GB free on system drive (C:\ Drive)
» 800 GB free on model run drive (e.g., D:\ Drive)
» 360 GB for model run storage

CAMERIDGE EYSTEMATICE i

Requesting the SCAG Model

# Request the model from SCAG

» Go to:
http://www.scag.ca.gov/DataAndTools/Pages/Docu
ments.aspx

» Download the Model Data Request Form
» Fill out and submit as instructed

# Cheryl Leising may be able to provide a Word
version that is easier to fill out

CAMBRIDGE SYETEMATICE ,

Installing the SCAG Model

# Install the User Interface (UI)
» Follow Instructions provide by SCAG
» See memo model installation v6.3.doc
» You may need administrator privileges

# Copy the model data and model table
» Place in a user-specified location
= Example: D:\SCAG
» One directory for each scenario
= Example: 16R16s3_set7_setting
» Model table with scenario information
= Example: SCAGModelv63q.bin

CAMBRIDGE SYETEMATICE ,

Running the SCAG Model

Setup a Scenario
» Click “Setup”
» Find the scenario to run

= Example: 16R16s3
= Make a copy (or work in place if you want)

» Set the correct directory on your system
= Check to make sure Input files are shown as “Exists”
» Click ‘OK’ (be patient while the system responds)

0 CAMERIDGE SYSTEMATICE

Running the SCAG Model

# Set the model to run “Feedback”

# Leave starting and ending
loops at 1 and 5

# Make sure the computer can
run for 6 to 10 days without
interruptions o

# Click ‘Initialization’ -

n
H
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http://www.scag.ca.gov/DataAndTools/Pages/Documents.aspx
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Running for Scenarios

# Quick Run with network changes only
» Trip tables and mode choice does not change
» Can be useful for:
= Testing roadway network changes
= Running assignment again with select link / zone analysis
# One-Loop Run

» Run one complete feedback loop, starting with final
loop from a full model

» Can be useful for:
= Large roadway and/or transit scenarios

9/21/2016

Quick Run: Network Change

# Copy your entire model scenario folder
» Alternate: Just backup the original networks and
assign folders
# Modify the input highway network file
» Remember: keep the route system up to date!
# Run the Check Network Attributes utility

ramou | ]

Quick Run: Network Change

# Double-check the scenario setup.
Change directory or filenames if
needed

# Set the model to run only a single
stage

# Click ‘Initialization’

% | i, =
# When asked if you want to delete all | & ===
files, click ‘No’ e

97 CAMBRIDGE SYSTEMATICE A

Quick Run: Network Change

# When initialization completes, click
on the ==mml button next to [ S
assignment
» Set steps as shown
» Click OK

# Click ‘Assignment’ to run
traffic assignment

» This will take several hours

One Loop Run

# Copy your entire model scenario folder

# Modify the inputs
» Highway network file
» Route system File
» Socioeconomic Data
# Run the Check Network Attributes utility

# Run the Mergenet Run utility
» This merges speed feedback results with the
modified network

One-Loop run

# Edit the scenario (click Setup)
» Set the Initial Time Option to a value of 2
» Click OK
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One-Loop run

# Set the dialog box to:
» Run Feedback

downs can change unexpectedly)

# Clickthe : button next to

» Run loop 6 to 6 (Be careful — the drop-

Initialization
» Set steps as shown
» Click OK
et e e s
[T
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One-Loop run

# Click the Initialization button to start the run
» This should take about a day to complete

# Did you get an error??

» Try closing and restarting TransCAD, then picking
up where you left off.

» Always double-check feedback settings and active
steps before starting a run

102 CAMBRIDGE SYSTEMATICE i
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Advanced Topics

- Matrix Files and OD Tables
» Matching matrix files to zones/centroids
» Visualizing trip table data
= Desire Lines
% Setting up Select Link and Zone Anlaysis
» Creating a query file

# Routable Networks
» Creating and updating a “.net” Network
» Interactive pathbuilding
% Basic Scripting
» Batch Recorder
» Simple Macro Creation

» Running assignment only with select analysis activated

Advanced Topics

Thank You!

105 CAMBRIDGE SYSTEMATICE ,
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