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Agenda
Morning Session
» Modeling 101
» Trip-based vs Activity-based models
» ACTC and MTC Models

Afternoon Session 
» VMT Analysis
» Model Convergence
» Cube Overview and Navigation
» Scripting in Cube
» Model Validation/Post Processing
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Introductions
CS Staff Introductions

Caltrans Staff Introductions 
» Roles and Responsibilities
» Software Knowledge

Training Goals
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Modeling 101
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Modeling 101

Inputs
Transportation 

Networks

Socioeconomic 
Data

External 
Data

Special 
Generators

Model 
Parameters

Outputs
Trips by 

Mode

Traffic 
Volumes

Congested 
Speeds

Transit 
Volumes

Summary 
Information
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Transportation Networks

Roadway Networks
» Contains roadway 

characteristics
 Number of Lanes
 Roadway Type (Freeway, 

arterial, etc.)

Transit Networks
» All fixed route transit service
» The model is sensitive to 

transit level of service 
(frequency, speed, coverage)

» Local/Express Bus, BRT, Rail

Inputs
Transportation 

Networks

Socioeconomic 
Data

External 
Data

Special 
Generators

Model 
Parameters
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Socioeconomic Data
Identifies demand for travel

Household data
» Average household size
» Median household income
» Number of resident workers
» And more…

Employment data
» By industry
» By wage level

Inputs
Transportation 

Networks

Socioeconomic 
Data

External 
Data

Special 
Generators

Model 
Parameters
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External Travel

Model travel:
» To/from the region
» Through the region

Inputs
Transportation 

Networks

Socioeconomic 
Data

External 
Data

Special 
Generators

Model 
Parameters
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Special Generators
Unique locations not well 
represented by employment data
» Ports
» Airports

Inputs
Transportation 

Networks

Socioeconomic 
Data

External 
Data

Special 
Generators

Model 
Parameters

453
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Model Parameters
Represent the way people behave
» How many trips are made?
» How far will people travel?
» What impacts decisions about travel mode?
» How does congestion impact travel?

Source Data
» California Household Travel Survey
» On-Board Transit Surveys
» Speed Surveys
» Big Data
» Traffic Counts

Inputs
Transportation 

Networks

Socioeconomic 
Data

External 
Data

Special 
Generators

Model 
Parameters
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Outputs: Trips
Information about each trip
» Start/end
» Time of day
» Mode of travel
» Purpose of trip
» Trip time and distance

Outputs
Trips by 

Mode

Traffic 
Volumes

Congested 
Speeds

Transit 
Volumes

Summary 
Information
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Outputs: Volumes and Speeds
By Time of Day
» Daily
» AM, PM, Mid-Day, Evening, Night
» AM and PM Peak Hours

Turn Movements
» Better estimated with assistance of 

base-year counts

Congested speed based on volume

Outputs
Trips by 

Mode

Traffic 
Volumes

Congested 
Speeds

Transit 
Volumes

Summary 
Information
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Outputs: Transit Volumes 
By Time of Day
» Peak and Off-Peak 
» Daily sum

By route or route group
» Also by stop, but with less accuracy

Useful for Big-Picture transit analysis
» Detailed analysis requires localized model 

refinement

Transit trips are removed from the highway 
network

Outputs
Trips by 

Mode

Traffic 
Volumes

Congested 
Speeds

Transit 
Volumes

Summary 
Information
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Outputs: Summary
Planning Tools
» Maps and charts
» Results presented for general understanding

 VMT, VHT, Delay
 Level of Service
 Trip Lengths
 Trip Patterns

Outputs
Trips by 

Mode

Traffic 
Volumes

Congested 
Speeds

Transit 
Volumes

Summary 
Information
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Trip-based vs Activity-based 
Models
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Trip Based Models
Simplified trip-making decisions with no 
connections between trips or people making 
them

Modeled at an aggregate zonal average level
» Average zonal income, household size, number of 

workers/household
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Trip- Based Example
Real-life behavior

Model translation: 6 independent trips
» 1 home-based school trip
» 1 home-based other trip
» 4 work-based trips
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Trip-based Model (ACTC)
Transportation Supply

Transportation Demand

How many trips?

Where will they go?

What mode?

What route?

Trip Generation

Trip Distribution

Mode Choice

Trip Assignment

Roadway / 
Transit Results Reports

Transportation 
Networks

Traffic Analysis 
Zones and Data

Feedback

Forecasts
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Tour-based Models
Trips are grouped into home-based or work-based 
tours resulting in consistency within the tour
» Mode choice is consistent between all legs of the tour

However, there is still no connection between tours or 
persons making them

Modeled at a disaggregate level

Travel example from before
» 1 home-based tour with intermediate stops
» 1 work-based tour
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Activity-based Models
Based on activities
» Temporal connections between tours 
» Members of a household considered together when selecting 

an activity-pattern (ie. parent dropping a child off at school)
» Each activity has start time and duration 
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Activity-based Model (MTC)

1. Population 
Synthesizer

2. Long Term Choices
Work Location School Location Auto Ownership

3. Daily Decisions
Individual 

Mandatory Tours Work SubtoursJoint Non-
Mandatory Tours

Individual Non-
Mandatory Tours

4. Tour Level Decisions 5. Trip Level Decisions
Tour mode Stops Trip mode Departure time

6. Traffic and Transit Assignment of Trips
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Activity vs Trip-based Models
Activity-based models predict travel at an individual level rather 
than TAZ averages

A sample zone has 2 households
» 3 persons, high income, 2 workers, 2 cars
» Household 1: two working parents, one school-aged child
» Household 2: two working adults, one senior

Trip-based model may predict 6.8 work trips, 3.2 school trips, 
and 8 other trips at the zonal level

Activity-based model may predict 8 work trips, 2 school trips, 
and 8 other trips
» Trip patterns, destinations, time of departure would all be very 

different
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Activity vs Trip-based Models
Activity-based models guarantee consistency 
between trips within tours as well as tours 
and household members

In activity-based models, trips can change 
time of departure based on congestion levels

However, in activity-based models, you have 
less control over the process 
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MTC and ACTC Models
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ACTC Model
Trip-based model that includes 10 counties 
» 9 Bay Area counties and San Joaquin County

Most recently re-calibrated in December 2015

Uses Citilabs Cube software to run

Uses the Plan Bay Area land use through year 2040

Includes more zones than the MTC model (4500 vs 
1454)

Much higher resolution in Alameda County and 
Contra Costa County 
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MTC Model
Activity-based model with 9 Bay Area counties

Current version is Travel Model One 0.6
» Very recently updated 

Uses Plan Bay Area land use through 2040

Used to evaluate projects for the RTP 

Large part of the model is a “black box”: many of the 
components are written in Java and Python and pre-
compiled

Highway and transit assignment are implemented in 
Citilabs Cube 
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MTC vs ACTC Model Zone Detail
Downtown SF
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MTC vs ACTC Model Zone Detail
Downtown Oakland

MTC ACTC
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MTC vs ACTC Model Zone Detail
Livermore

MTC ACTC
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MTC vs ACTC Model Zone Detail
Richmond/El Cerrito

MTC ACTC
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When to Use MTC vs ACTC 
MTC
» Analysis outside 

Alameda or Contra 
Costa County

» Express lanes 
analysis

» Benefit/cost analysis

ACTC
» Alameda County, 

Contra Costa County, 
San Joaquin County

» Transportation 
projects that are 
large but unlikely to 
result in changes to 
where people work or 
live
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CS Projects Using MTC and 
ACTC Models

MTC
» Core Capacity Study
» Inter-regional 

Express Lanes
» Analysis of BART 

State of Good Repair

ACTC
» BART to Livermore 

DEIR
» Alameda County 

Goods Movement
» Port of Oakland 

Study
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MTC vs ACTC Projects
What are some Caltrans projects using the 
two models?
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VMT, VHT, and other acronyms
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VMT Background
Vehicle-miles-traveled is an important metric 
correlated with Greenhouse Gas Emissions 
(GHG)

California law (SB743) requires all new 
development projects be assessed in terms 
of their impact on VMT
» OPR has issued guidance on how land use and 

transportation projects need to be evaluated
» New projects should meet the threshold of 15% 

below average regional VMT (more on this later)
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VMT Analysis
Highway- facility VMT analysis that calculates VMT 
on particular facility or set of facilities
» Can be conducted for different geographical areas such as 

counties
» Can be conducted based on facility type or speed at which 

the facility operates 
» This has been done by many agencies over the years

Zonal VMT analysis that calculates travel generated 
by a set of zones 
» This is the analysis required by SB 743
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Facility VMT
Calculated by multiplying daily number of 
vehicles by link distance

If VMT is segmented by speed bin, each 
facility is grouped into a speed bin based on 
operational speed and then the VMT is 
calculated 

VMT that occurs within each county of 
jurisdiction can be calculated by identifying all 
highway facilities within the jurisdiction and 
adding up VMT
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Zone-based VMT
For a given TAZ system, can get vehicle trip tables, 
combine them with skims and calculate vehicle-miles 
traveled

For activity-based models, can get total household 
VMT by adding up all auto trips in the trip list 
multiplied by trip length
» Since the home zone of the trip maker is known for all trips, 

the total VMT will include non-home-based VMT

For trip-based models, can only get home-based 
VMT because home zone is not available for non-
home based trips
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VHT and VHD
Vehicle-hours traveled is another metric 
frequently used in transportation analyses
» Calculated by multiplying the link travel time by link 

volume (should be done by time period)

Vehicle-hours of delay is a metric used to 
evaluate the impact of a project on system-
wide level of congestion
» Calculated by multiplying the difference in 

congested link travel minus free-flow link travel 
time by link volume
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PMT, Vehicle Occupancy 
Passenger-miles traveled is a metric used to capture 
the total travel including non-auto travel
» Calculated by multiplying the distance between origin and 

destination (based on skims) by the number of trips occurring 
between origin and destination

Vehicle occupancy refers to the total number of auto 
person trips divided by number of vehicles

Vehicle ridership refers to the total number of 
motorized trips divided by number of vehicles 
(includes transit trips)
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VMT Calculation Example 
Corridor VMT that falls within 
different non-attainment areas 
(PM25, Ozone) as well as 
economically disadvantaged 
areas
California Statewide Travel 
Demand Model (CSTDM) was 
used to determine volumes on 
different facilities
The loaded networks were 
overlaid with non-attainment 
area zones in ArcGIS to extract 
facilities that fell within these 
areas 

Economically Disadvantaged Areas
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Model Convergence
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Background
Model convergence can refer to either:
» Traffic assignment convergence
» Model feedback convergence

Travel demand models typically use user equilibrium 
traffic assignment algorithm, where each user 
minimizes his or her travel time and is assumed to 
have prefect knowledge of the system travel time

Paths are built and vehicle are re-assigned until any 
paths that are being used between an origin and a 
destination have the same travel time
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Traffic Assignment Convergence
There is no deterministic solution to the user equilibrium 
assignment process- it’s an iterative process

At the end of each iteration a relative gap parameter is 
calculated that represents the change from previous iteration-
the smaller the change, the closer you are to convergence

Many models use relative gap of 0.01, which usually is 
insufficient to reach convergence

Some other models including the ACTC model use a maximum 
number of iterations, instead of relative gap, which is not ideal

When the assignment is not well converged, a local change to 
the highway network results in volume differences far away
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Traffic Assignment Convergence
Volume Diff: No Dublin Blvd extension in Livermore

MaxIters=50 Relative gap=0.0001

Volume decrease
Volume increase
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Speed Feedback Convergence

Most urban area models run speed feedback in order 
for trip distribution and mode choice steps to respond 
to the congested speeds on the highway network
» If free-flow speeds are used for trip distribution and mode 

choice, there will be too many long trips as well as a high auto 
mode share

» If congested speeds from a prior run with no speed feedback 
are used, there will be too many short trips and transit trips
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Should Speed Feedback be Run?

YES
» Significant addition of 

capacity on the 
highway (new 
express lane on I-
580)

NO
» Interchange project
» Addition of one lane-

mile on a minor 
arterial 
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Upcoming Homework
Add I-580 HOT lanes near Livermore

Run with and without speed feedback 

Run with higher level of traffic assignment 
convergence

Compare different model runs to No Project 
scenario
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Cube Overview
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Cube Software Overview
Cube Base includes the interface 
Cube Voyager executes scripts
Cube Scenario Manager allows to manage scenarios
Cube Application Manager maintains the model and 
allows running it using a flowchart structure
Cube GIS incorporates ESRI interface into Cube
Version & build
» Version I have open: Version 6.1.0
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Cube Overview
Most models implemented in Cube use either a bat 
file to run the model or the Scenario Manager
» California Statewide Travel Demand Model uses scenario 

manager
» In all cases, routines are implemented using scripts

Some of the more common procedures include 
matrix calculation, highway assignment, trip 
generation, trip distribution and transit assignment 

Cube Base is used to view files, edit networks, and 
analyze results
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Cube Base User Interface
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Editing Link Attributes 
Click on Link

Double-click on attribute

Make desired changes

Click on       to save 
changes or      to cancel 
changes

Click on “Save Edit Log” to 
save log file

Saved log file can be 
played on a different 
network to apply the same 
changes  

Presenter
Presentation Notes
Demonstrate saving log file and playing log file in class
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Adding New Links
Right-click on similar link and click copy

Right-click on desired location and click paste

Drag and drop mouse from start to end of new link

Edit link attributes (note that the distance field populates itself and rest 
of attributes are copied from previous link)

In order to create a new link without any attributes, click on Add Two-
way or Add One-Way in the Home tab

Presenter
Presentation Notes
Do a demo
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Adding Attributes
In order to create a new attribute, click 
on Add in the Link tab

Name new attribute and click OK

Click on a link and scroll all the way 
down to check new attribute. The default 
value of the attribute is 0, but this can be 
changed by editing and saving.



56

Adding Attributes (Calculate)
Click on Compute under Link Tab

Name the new attribute

Right click inside white window and 
click Insert

Type formula for new attribute

Type formula under Condition to 
select the links which are to be 
computed, remaining links will have a 
default value of 0. If no condition is 
specified, all links are computed.

Click Apply and then Close
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Adding Color Scheme
Click on Color in 
Home Tab

Click on Insert 
and then choose 
desired settings

Rows can be 
moved up or down 
to choose how the 
theme appears

Save project file to 
save changes to 
the theme
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Bandwidth Plots 
Click on Multi-
Bandwidth in 
Analysis Tab

Choose 
attribute(s), Color 
and Size. Up to 8 
attributes can be 
chosen

Click Ok
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Adding Labels
Click on 
Post All in 
Home Tab 
in the Post 
Link section

Choose 
attributes to 
Label and 
appropriate 
settings

The Post 
Single 
option can 
be used to 
label links 
by clicking 
on them 
instead

Presenter
Presentation Notes
Similar method for adding node labels
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Displaying Paths
Click on Build in Analysis tab

Specify attribute for shortest path 
calculation and click Done

Type in Origin and Dest zones (you 
may also click on the map to select 
zones). Click on Display
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Exporting Links
Go to File -> Export -> Export

Select location and filename

Select “save as type” to save 
any of the following:
» Link Shape File
» Node Shape File
» Link DBF file
» Node DBF file

Shape files are output as 
standard GIS Shape Files

DBF files are output as single 
DBFs with all the links/nodes 
as rows
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Scripting in Cube
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Adding Matrices
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Aggregating Matrices
1 5
2 5
3 5
4 5
5 4
6 4
7 19
8 19
9 19

10 17

Sample Correspondence file:

• No headers

• First column TAZ, 
second column 
aggregation index
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Converting Matrix to .csv
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Select Link Analysis
West Bound

East Bound
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Select Link Analysis Results
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Comparing Network Volumes
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Exporting Network Links
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Working with Master Networks
By defaults all base attributes from 
Master Network are transferred to 
the output year network

If improvement year of a project is 
less than the desired output year, 
then non-zero attributes from the 
improvement are transferred to the 
output year network

For example, in this instance if a 
2020 network is output, the number 
of lanes for the specific link shown 
will be 5, and the rest of the 
attributes will be the same as base

The ACTC master network has up 
to three improvements listed, but 
the network and script can be 
modified to accommodate for more

Base 
Attributes

Improvements
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Working with Master Network
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Model Validation/Post 
Processing
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Model Validation
Observed data sources:
» California Performance Measurement System 

(PeMS)
» Big Data- INRIX, TomTom, HERE, StreetLight, 

AirSage, ATRI
» HPMS
» Arterial counts
» TAMS- Truck Activity Monitoring System 

(http://freight.its.uci.edu/tams/)
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Model Comparison to Counts
Statistics 
» R-Squared
» % RMSE
» Volume / Count 

Ratio
Screenlines
Corridor Review
Highest Errors
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Post-Processing
Pivot point approach is most commonly used 
for post-processing
» Is the model too low in the base year?

 Then the forecast is increased by the same amount

» Is the model too high in the base year?
 Then the forecast is decreased by the same amount

Increases or decreases can be calculated as 
an absolute number or percent change
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Post-Processing Approaches

𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝑡𝑡𝑟𝑟𝑟𝑟𝑟𝑟𝑟𝑟𝑟𝑟 = 𝑅𝑅𝑅𝑅𝑅𝑅 𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉 �
𝐶𝐶𝐶𝐶𝐶𝐶𝐶𝐶𝐶𝐶 𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉

𝑅𝑅𝑅𝑅𝑅𝑅 𝐵𝐵𝐵𝐵𝐵𝐵𝐵𝐵 𝑌𝑌𝑌𝑌𝑌𝑌𝑌𝑌 𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉

𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝑡𝑡𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑 = 𝑅𝑅𝑅𝑅𝑅𝑅 𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉
+ 𝐶𝐶𝐶𝐶𝐶𝐶𝐶𝐶𝐶𝐶 𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉
− 𝑅𝑅𝑅𝑅𝑅𝑅 𝐵𝐵𝐵𝐵𝐵𝐵𝐵𝐵 𝑌𝑌𝑌𝑌𝑌𝑌𝑌𝑌 𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉𝑉

𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝑡𝑡𝑎𝑎𝑎𝑎𝑎𝑎 =
𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝑡𝑡𝑟𝑟𝑟𝑟𝑟𝑟𝑟𝑟𝑟𝑟 + 𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝐹𝑡𝑡𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑

2

Use % Growth (e.g., traffic increases by 30%)

Use Volume Growth (e.g., traffic increases by 5,000 vehicles)

Use the Average 
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Future Topics
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Future Topics
Intro to TransCAD and differences from 
CUBE

Data collection methodology (PeMS)

Detailed post processing spreadsheets

CS-developed tools for district modelers
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Additional Info
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MTC Model Detailed Structure
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